Programmhilfe

Renderstile

Renderstile-Dialog

Stil anlegen

Icon für Stil erstellen

Stil aus pCon.catalog laden

Stil anwenden

Stil dauerhaft verwenden

pCon.planner_Renderstile_39_Button_Renderstile

Die Renderstile finden Sie in der Gruppe Darstellung, Register Ansicht.

Hier kreieren sie eigene Darstellungsmodi, indem Sie zum Beispiel Linienstärken, Kontrast oder Umgebungsverdeckung ändern. Diese Renderstile können, wie auch die vordefinierten Modi (Drahtgitter, Verdeckt, etc), beliebigen Arbeitsbereichen zugeordnet werden.

Außer im Planungsbereich lassen sich diese Stile auch im Layout-Bereich sowie für Echtzeitabbildungen verwenden.

Renderstile-Dialog

Nach einem Klick auf den Renderstile-Button öffnet sich der Renderstile-Dialog.

Der Renderstile-Dialog besteht aus einer Werkzeugleiste und zwei Fenstern. Im linken Fenster werden die geladenen Stile angezeigt (im linken Bild noch leer). Das rechte Fenster beherbergt die Register Allgemein, Bilder, Nachbearbeitung sowie Effekte.

pCon.planner_Renderstile_40_Dialog_leer

Die Buttons der Werkzeugleiste bieten die folgenden Funktionen:

itemAdd

Renderstil anlegen

itemRemove

Renderstil löschen

acCatalogOnline

Renderstil aus Online-Katalog laden

acFileOpen

Renderstil laden

acFileSave

Renderstil speichern

acFileSaveAs

Renderstil speichern unter

 

 

 

 

Stil anlegen

Klicken Sie auf den itemAdd Button, um einen neuen Renderstil zu erstellen. Daraufhin wird im linken Fensterbereich des Dialogs ein Standard-Icon sichtbar, das den Stil repräsentiert. Dieses Icon kann geändert werden.

Über die Register des Renderstile-Dialoges können Sie dem Stil verschiedene Eigenschaften zuweisen und differenzierte Einstellungen vornehmen.

Bereits während der Erstellung des Stils sehen Sie, wie sich die Einstellungen, die Sie für den Renderstil machen, auf die Echtzeitansicht auswirken.

Register Allgemein

Im Register Allgemein stehen Ihnen die folgenden Einstellungen zur Verfügung:

Einstellung

Beschreibung

Basis

Wählen Sie einen der Darstellungsmodi Drahtgitter, Verdeckt, etc.

Farben

Hintergrund

Farbe für den Hintergrund der Planung festlegen

Linien

Farbe der Linien in der Planung festlegen

Flächenfarbe

Farbe der Flächen festlegen (nur bei Basis Verdeckt)

Transparenz

Transparenz der Flächenfarbe (bei Basis Verdeckt)

Linienstile

Stil

Linienstil festlegen

Linienstärke

Dicke der Linien in der Planung

Details

Hervorhebung für Detail-Linien darstellen

Transparenz

Transparenz für die Linien einstellen

 

pCon.planner_Renderstile_47_Allgemein_Grundmodus

pCon.planner_Renderstile_48_Beispiel_Renderstil

Beispielstil: Basis Verdeckt; Linienfarbe in RGB 58, 58, 58; Hintergrund und Flächenfarbe weiß, keine Transparenz; Linienstil 4, geringe Linienstärke, hohe Details, keine Transparenz.

Register Bilder

Über das Register Bilder binden Sie Abbildungen (z.B. Logos) in Ihren Renderstil ein. Mit Hilfe der Werkzeugleiste (siehe roter Rahmen im folgenden Bild) fügen Sie Bilder hinzu, löschen sie, bewegen sie in den Vorder- bzw. Hintergrund Hintergrund oder exportieren sie.

pCon.planner_Renderstile_49_Bilder_Werkzeugleiste

Nachdem ein Bild eingefügt wurde, können Sie außerdem seine Größe, Transparenz, Ausrichtung und die Abstände zu anderen Elementen festlegen.

pCon.planner_Renderstile_50_Bildeeigenschaften

Register Nachbearbeitung

Die Einstellungen werden mit Aktivierung der Funktion Nachbearbeitung verwenden für den Renderstil übernommen.

Im Register Effekte können Sie sowohl Helligkeit als auch Kontrast und Sättigung anpassen.

pCon.planner_Renderstile_55_Effekte1

Mit dem Farbton-Mapping weisen Sie der Darstellung einen oder mehrere Farbtöne zu. Der für die Darstellung verwendete Farbton ist abhängig von der Helligkeit des jeweiligen Pixels. So gehen Sie vor:

1.Klicken Sie unter Farben auf das Farbe hinzufügen-Symbol itemAdd. Im sich öffnenden Farbe-Dialog wählen Sie eine vorgegebene Farbe aus oder nehmen eigene Einstellungen vor.
2.Wiederholen Sie den Vorgang, um Ihre Farbpalette wie gewünscht zusammenzustellen.

pCon.planner_Renderstile_Effekte_Farbtonmapping

3.Der oberste Farbton wird den dunklen Bildbereichen, der unterste Farbton den hellen Bildbereichen zugeordnet. Sie können die Reihenfolge der ausgewählten Farben ändern, indem Sie einen der farbigen Balken im Bereich Farben anklicken und ihn mit gedrückter linker Maustaste an die gewünschte Stelle ziehen (siehe Abbildung auf der linken Seite).
4.Um eine Farbe zu löschen, klicken Sie bitte den entsprechenden Farbbalken an und nutzen den Button Farbe löschen itemRemove.

Mit einem Klick auf den Stern-Button acFavStar laden Sie voreingestellte Farbschemata.

Register Effekte

Dieses Register enthält Einstellungen zu Blooming und Umgebungsverdeckung. Diese beiden Effekte kommen bereits im realistischen Darstellungsmodus zum Tragen.

pCon.planner_Renderstile_55_Effekte_neu

Möchten Sie die Stärke der Umgebungsverdeckung oder des Bloomings verändern, legen Sie dafür einen eigenen Renderstil an. Dieser muss auf dem Darstellungsmodus Realistisch basieren (Renderstile --> Register Allgemein --> Basis: Realistisch).

Umgebungsverdeckung (Ambient Occlusion)

Die Umgebungsverdeckung steuert die Intensität der diffusen Schatten in der Planung. Der Effekt wird besonders in Raumecken und um die Auflageflächen von Objekten herum sichtbar.

Einstellung

Beschreibung

Intensität

Stärke der Schatteneffekte

Radius

Reichweite des Schatteneffekts – großer Radius = größerer, aber weicherer Schattenbereich

Blooming

Dieser Effekt steuert die Lichtabstrahlung von selbstleuchtenden und sehr hellen beziehungsweise glänzenden Objekten. Diese Objekte erhalten eine leichte Lichtaura.

Einstellung

Beschreibung

Intensität

Stärke des Leuchteffekts

Schwelle

Damit Blooming wirksam wird, muss eine Farbe diese Leuchtkraftschwelle überschreiten

pCon.planner_Renderstile_55_Effekte_neu_beispiel

 

Namen und Icon für Stil vergeben

pCon.planner_Renderstile_51_Icon_Standard

Ein eigenes Icon für einen Renderstil legen Sie im Register Allgemein an. Klicken Sie auf den Button rechts im Abschnitt Basis.

pCon.planner_Renderstile_52_Icon_own

Je nachdem welchen Ausschnitt der aktive Arbeitsbereich zeigt, wird ein entsprechendes Miniaturbild erstellt. Das Icon kann beliebig oft neu generiert werden.

pCon.planner_Renderstile_53_Anzeige_Icon_links

Sobald Sie ein Icon erstellt haben, wird das Standard-Icon im linken Fensterbereich ersetzt (vgl. Bild links). Wenn Sie das Icon markieren und danach erneut klicken, können Sie dem Stil einen eigenen Namen geben. Alternativ nutzen Sie zum Umbenennen F2.

Stil aus pCon.catalog laden

Sie können auf auf vordefinierte Stilen zurückgreifen. Klicken Sie auf den Katalog-Button acCatalogOnline, im Renderstile-Dialog, um die Seite mit den Renderstilen zu öffnen. Nach einem Klick auf einen der Stile wird dieser automatisch in den Dialog geladen.

Stil anwenden

 

pCon.planner_Renderstile_54_Weitere_Stile

Der Zugriff auf die Renderstile erfolgt zum einen über den Renderstile-Dialog. Durch Doppelklick auf einen der dort hinterlegten Stile wird dem aktiven Arbeitsbereich der gewählte Stil zugewiesen.

Zum anderen können Sie Ihre Renderstile auch im aktiven Ansichtsfenster auswählen. Öffnen Sie das Drop-Down-Menü mit den Darstellungsmodi. Am unteren Ende der Liste sehen Sie die angelegten Renderstile und aktivieren den gewünschten Stil per Klick.

Natürlich können Sie die Stile auch über das Register Ansicht und die Gruppe Darstellung auswählen.

Stile dauerhaft verwenden

Renderstile werden nicht automatisch gespeichert. Verwenden Sie das Speichern-Icon im Dialog Renderstile, um Ihre Renderstile für die spätere Verwendung zu speichern.

Um einen Renderstil mit einer bestimmten Planung zu verwenden, speichern Sie ihn bitte in einem Ordner mit dieser Planung ab.

Damit ein Renderstil für die Arbeit an anderen Planungen zur Verfügung steht, muss er gespeichert und als Favorit markiert werden. Dazu gehen Sie wie folgend beschrieben vor:

1.Öffnen Sie den Renderstile-Dialog und selektieren Sie den Renderstil, den Sie dauerhaft im pCon.planner nutzen möchten.
2.Klicken Sie auf das Favorit-Icon im Register Allgemein im Abschnitt Basis.
3.Sollte der Renderstil bisher nicht gespeichert worden sein, fordert Sie der pCon.planner auf dies zu tun, da nur gespeicherte Stile als Favoriten markiert werden können.

Nach dem Speichern wird im linken Fensterbereich des Renderstile-Dialogs der entsprechende Stil mit einem Sternchen versehen angezeigt (siehe nächstes Bild).

pCon.planner_Renderstile_54_Favorit