Program help

Render styles

Render Styles Dialog

Creating a Style

Creating a Style Icon

Loading a Style from pCon.catalog

Using a Style

Repeated Use of Style

pcon.planner_Render_styles_01

You can find the Render Styles under the View tab in the group Render.

Here you can create custom Render Modes by changing, for example, line thickness, contrast or ambient occlusion.

These render styles can be assigned to any particular Viewport, as can the pre-defined modes such as Wireframe, Hidden Line and so on. You can use these styles not only in the design area but also in the Layout Area as well as for real-time images.

Render Styles Dialog

If you click on the Render Styles button, the render styles dialog will open.

The dialog is made up of a toolbar and two windows,  The styles already loaded will be shown in the left hand window (this is still empty in the screenshot on the left). The window on the right contains the tabs Common, Images, Post Processing and Effects.

pcon.planner_Render_styles_02

The buttons on the tool bar provide the following functions.

itemAdd

Create a new render style

itemRemove

Delete a render style

acCatalogOnline

Load a render style from online catalog

acFileOpen

Load a render style

acFileSave

Save a render style

acFileSaveAs

Save a render style as

 

 

 

 

 

 

 

 

Creating a Style

Click on the itemAdd button to create a new render style. A standard icon to represent the style will then appear in the left hand side of the dialog. It is possible to modify this icon.

The tabs for the Render Styles dialog will enable you to assign a variety of properties to the style and try different settings.

Even while you are creating a style you will see the effect on the real-time view of the settings you make for the render style.

Common Tab

Under the Common tab, the following settings are available:

Setting

Description

Base

Select from one of the Render Modes: Wireframe, Hidden Line, etc.

Colors

Background

Set the plan’s background color

Lines

Set the plan’s line color

Face Color

Set the fill color (only for Hidden Lines)

Transparency

Fill Color transparency (for Hidden Lines)

Line Style

Style

Set the line style

Line Width

Set the plan’s line thickness

Details

Highlighting detail lines

Transparency

Adjust line transparency

 

pCon.planner_Render_styles_47_Common_Base

pCon.planner_Render_syiles_48_Beispiel_Renderstyle

Sample style: Base Mode Hidden line; Lines color RGB 58, 58, 58; Background and Face color white, no Transparency; 

Line Style 4, Line Width small, high level of Details, no Transparency.

Images Tab

Under the Images tab, you can embed images (e.g. logos) into your render style. The toolbar (see red frame in the screenshot below) enables you to add and delete images, move them into the foreground or background and also export loaded images separately.

pCon.planner_Render_styles_49_Images_Tools

When an image has been incorporated, it is also possible to adjust its Size, Transparency and Alignment.

pCon.planner_Render_styles_50_Images

Post Processing Tab

When the Use Post Processing button is enabled, the settings will be adopted for the Render Style.

This tab contains options for adapting the Brightness, the Contrast and the Saturation.

pcon.planner_Render_styles_Effects

Tone Mapping assigns one or more colors for the rendering. The shade used for the rendering will be dependent on the brightness of the particular pixel. This is how to use the function.

1.Under Colors, click on the Add color symbol itemAdd and then select one of the colors offered there. You can also make your own color setting.
2.Under Colors, click on the Add color symbol and then select one of the colors offered there. You can also make your own color setting.

pCon.planner_Render_styles_effects_tone_mapping

3.The top shade will be assigned to the dark areas of in the image and the lower shade will be assigned to the lighter areas. You can influence this order by clicking one of the colored bars in the Colors area, dragging it with the mouse button down and dropping it at the selected place (see the screenshot).
4.If you want to delete a color, click on the relevant bar and use the Delete color itemRemove button.

Clicking on the Asterisk button acFavStar you can load predefined color schemes.

Effects Tab

This tab contains the settings for Blooming and Ambient Occlusion. Both of these effects are already shown in Realistic rendering mode.

pcon.planner_Render_styles_Effects_new

If you would like to adjust the strength of the ambient occlusion or blooming, create your own render style. You will need to base it off of the Realistic render mode (Render Styles --> Common tab --> Foundation: Realistic).

Ambient Occlusion

Ambient occlusion controls the intensity of the diffused shadows in the plan. The effect is particularly visible in room corners and around contact surfaces.

Setting

Description

Intensity

Strength of the shadow effect

Radius

Range of the shadow effect – large radius = larger, yet softer shadow area

Blooming

This effect controls the light emission from self-luminous and very bright as well as shiny objects. These objects will display a slight light aura.

Setting

Description

Intensity

Strength of the lighting effect

Threshold

For blooming to take effect, a color must exceed this luminosity threshold

pcon.planner_Render_styles_Effects_new_example

Assigning a Name and Icon for Your Style

pCon.planner_Render_styles_51_Icon_Standard

You can set an icon for your own Render Style under the Common tab. Click on the button on the right in the section Base.

pCon.planner_Render_styles_52_Icon_own

Depending on which excerpt is showing in the active viewport, a miniature image of it will be created. This icon can be re-created as often as you like.

pCon.planner_Render_styles_53_Icon_left

As soon as you have made an icon, it will replace the default icon in the left-hand pane of the window, see screenshot on left. If you select the icon and then click again, you will be able to give the style its own name. For renaming you can also use F2.

Loading a Style from pCon.catalog

You can make use of various pre-defined styles. Click on the Catalog button acCatalogOnline in the Render Style dialog to open the Render Styles page. The pCon.Catalog client will open and load the page containing the render styles. The one you click on will be loaded automatically into the dialog.

Using a Style

pCon.planner_Render_styles_54_Additionals_Styles

Render Styles can be accessed through the Render Styles dialog. Double-clicking on one of the styles available there means that it will be assigned to the active viewport.

You can also select your Render Style directly from the currently active Viewport. Open the drop down menu with the render modes. You will find the created render styles at the bottom of the list. These can be enabled by clicking on the desired style.

A further way is to select styles from the View tab, Render group.

 

Repeated Use of Style

Render Styles are not saved with the plan. A render style must be saved and marked as a Favorite if it is to be available when pCon.planner is next started. This is how:

1.Open the Render Styles dialog and select the render style you wish to adopt on a permanent basis for future renderings in pCon.planner.
2.Click on the Favorite icon in the Base group of the Common tab.
3.If the render style has not already been saved, pCon.planner will ask you to do so, as only stored styles can be marked as favorites.

When it has been saved, the relevant style will be displayed with a star in the left-hand pane of the render style dialog (see next screenshot).

pCon.planner_Render_styles_55_Favorite

If you click again on the Favorite icon, the star will disappear from the style icon and the relevant render style will not be shown the next time pCon.planner starts. However, the style will be kept and can be marked as Favorite again at any time. It must first be loaded from the Open button in the render style dialog.

It is not only a single render style that can be marked with the Favorite icon. Any number of render styles can be marked as favorites and can thus be visible in the list of render styles.

Render Styles can also be exchanged between users.